Changes between Version 27 and Version 28 of access/BomAccessDocumentation/bom-nwptools


Ignore:
Timestamp:
Jun 25, 2019 12:40:20 PM (4 months ago)
Author:
as2291
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • access/BomAccessDocumentation/bom-nwptools

    v27 v28  
    6464=== obsmon ===
    6565
    66 * Dependencies have been kept to a minimum in obsmon in order to ensure maximum portability. Apart from standard library packages, direct use is made of numpy, matplotlib, netCDF4 and cartopy.
     66* Apart from standard library packages, direct use is made of {{{numpy}}}, {{{matplotlib}}}, {{{netCDF4}}}, {{{cartopy}}} and {{{odbserver}}}. odbserver is not available through conda download, it is installed separately.
     67
     68* odbserver is sensitive to the compiler environment. If the version of gcc (for the underlying C++ code) is not compatible with the installation version then a {{{Exception: Can't find libOdb.so}}} error is raised.
    6769
    6870* Cartopy is usually made available through iris and that has some compatibility issues as noted elsewhere. Some versions of cartopy have issues with some versions of matplotlib. See [https://code.metoffice.gov.uk/trac/varpy/ticket/67 varpy ticket 67] and [https://code.metoffice.gov.uk/trac/varpy/ticket/185 varpy ticket 185] for examples.