Changes between Version 26 and Version 27 of access/BomAccessDocumentation/bom-nwptools


Ignore:
Timestamp:
Jun 24, 2019 5:01:40 PM (3 weeks ago)
Author:
Vinod Kumar
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • access/BomAccessDocumentation/bom-nwptools

    v26 v27  
    117117
    118118    {{{
    119     module load conda
     119    module load conda/python27 (we use the conda env already installed by CoE)
    120120    conda activate <conda env name>
    121121    conda remove mule (if you have them installed already)
     
    123123    }}}
    124124
    125     You can verify the install by "conda list".
     125    Do the same for um_utils. You can verify the install by "conda list".
    126126
    127127  2. The iris version that works with both GES and RES is found to be iris=1.13.0. Later versions of iris (tested 2.0.0) were found to have a compatibility issue with numpy by calling the dask module. Basically, later version of iris calls dask which inturn calls {{{numpy.nancumprod}}} function, available only on numpy 1.13.0 or later. However, upgrading to a later version (numpy1.16.4) resulted in an unstable installation with further dependency issues. Hence, we reverted back to the earlier numpy=1.11.3 version. However, the iris=1.13.0 is not compatible with eccodes and cdo packages available via the conda-forge channel. Hence we had to omit these two modules from our installation.