Changes between Version 23 and Version 24 of access/BomAccessDocumentation/bom-nwptools


Ignore:
Timestamp:
Jun 24, 2019 3:32:22 PM (4 months ago)
Author:
as2291
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • access/BomAccessDocumentation/bom-nwptools

    v23 v24  
    6868* Cartopy is usually made available through iris and that has some compatibility issues as noted elsewhere. Some versions of cartopy have issues with some versions of matplotlib. See [https://code.metoffice.gov.uk/trac/varpy/ticket/67 varpy ticket 67] and [https://code.metoffice.gov.uk/trac/varpy/ticket/185 varpy ticket 185] for examples.
    6969
    70 * Cartopy requires data files that are automatically downloaded into a user's {{{.local}}} directory if the are not found in a pre-installed location. This must be avoided as it will break any suites that do not run cartopy on a data-mover node (i.e., all of them) as shared and compute nodes do not have external access. A shared location that is defined in the installed package for these files is essential.
     70* Cartopy requires data files that are automatically downloaded into a user's {{{.local}}} directory if the are not found in a pre-installed location. This must be avoided as it will break any suites that do not run cartopy on a data-mover node (i.e., all of them) as shared and compute nodes do not have external access. A shared location for these files (that is defined in the installed package) is essential.
    7171
    7272* The sphinx package, pep8, and associated modules are used for automatic documentation generation and code tidying respectively. These are not required in the operation of the code but they are for admin purposes in varpy. Sphinx and pep8 are part of the Met Office scitools environment.