Changes between Version 1 and Version 2 of access/BomAccessDocumentation/bom-conda/nwptools_py/nwptools_py2/development


Ignore:
Timestamp:
Nov 28, 2019 11:52:19 AM (3 weeks ago)
Author:
Vinod Kumar
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • access/BomAccessDocumentation/bom-conda/nwptools_py/nwptools_py2/development

    v1 v2  
    1 = nwp_pytools2.2019.11 =
     1= nwptools_py2.2019.11 =
    22
    3 This environment is fairly similar to the [wiki:access/BomAccessDocumentation/bom-conda/nwp-pytools/nwp-pytools27 nwp_pytools27] environment available on Raijin, in terms of the packages. The `nwp_pytools2.2019.11` environment have some additional packages installed compared to the `nwp_pytools27`. Also, some packages versions/tags are different between the two environments. The nwp_pytools2 environment is build using `conda/4.6.14` and one on Raijin using a different version. We couldn't identify which conda version is used to build the Raijin environment (`conda 4.5.11??`) and hence the failure to reproduce. The packages which are different are given in the table below:
     3This environment is fairly similar to the [wiki:access/BomAccessDocumentation/bom-conda/nwp-pytools/nwp-pytools27 nwp_pytools27] environment available on Raijin, in terms of the packages. Note that the mule and um_util packages are installed manually from source code, similar to `nwp_pytools27`.
    44
    5 || '''Package''' || '''Package name in nwp_pytools27 (Raijin)''' || '''Package name in nwp_pytools2 (Gadi)''' ||
     5The `nwptools_py2.2019.11` environment have some additional packages installed compared to the `nwp_pytools27`. Also, some packages versions/tags are different between the two environments. The `nwptools_py2` environment is build using `conda/4.6.14`, different to that used on Raijin to build `nwp_pytools27`. We couldn't identify which conda version is used to build the Raijin environment (`conda 4.5.11??`) and hence the failure to reproduce.
     6
     7The packages which are different are given in the table below:
     8
     9|| '''Package''' || '''Package name in nwp_pytools27 (Raijin)''' || '''Package name in nwptools_py2 (Gadi)''' ||
    610|| _libgcc_mutex || Not available || _libgcc_mutex=0.1=ma ||
    711|| alabaster || Not available || alabaster=0.7.12=py_0 ||
     
    1317|| snowballstemmer || Not available || snowballstemmer=2.0.0=py_0 ||
    1418|| windspharm || windspharm=1.7.0=py27_1000 || windspharm=1.7.0=py27_1001 ||
     19
     20
     21The list of packages in the environment is given as a yml file [wiki:./nwptools_py2.2019.11_dev.yml here]